Keka
the Mac OS X file archiver
Download Changelog Forum Help Trac Project

Opened 7 years ago

Closed 7 years ago

#37 closed task (worksforme)

My Benchmark Testing of Keka 0.1.4.3

Reported by: UpdateNut Owned by:
Priority: trivial Milestone: Future ideas
Component: Version: 1.0.X
Keywords: benchmark Cc:

Description

I regularly visit this remarkable site for compression benchmarking (http://www.maximumcompression.com/index.html), and wondered: How would Keka fare if it were in this test? Fortunately, the creator of the site has made his test files freely available, so I was able to run my tests and see how well Keka would do. The end result: Keka 0.1.4.3 overall scored no. 68 out of 216 compressors. In comparison to well-known compressors, this puts it behind WinRAR 4.1b3, Stuffit 14, and 7-Zip 9.25a, but ahead of WINZIP 8.0. I've made a .rtf file with my full results, and will reproduce it here.

/*Current compression records. All percentages will be rounded to the nearest ten thousandth. Only archive formats with highest compression levels included.*/

===Standard tests: Compression of Maximum Compression.com's test files===

===Test System: iMac with Core 2 Duo 2.66 GHz, 2 GB DDR2 800 RAM, 320 GB HDD, Mac OS X v10.5.8===

==Text==
=Compression of .txt file=
Original size 2,988,578 bytes
Keka 0.1.4.3 .7z ultra: 573,274 bytes, or 80.8178%
Place no. 100

=Compression of .log file=
Original size 20,617,071 bytes
Keka 0.1.4.3 .7z ultra: 839,075 bytes, or 95.9302%
Place no. 117

=Compression of .dic file=
Original size 4,067,439 bytes
Keka 0.1.4.3 .7z ultra: 851,853 bytes, or 79.0568%
Place no. 68

==Executable==
=Compression of .exe file=
Original size 3,870,784 bytes
Keka 0.1.4.3 .7z ultra: 1,406,591 bytes, or 63.6613%
Place no. 49

=Compression of .dll file=
Original size 3,782,416 bytes
Keka 0.1.4.3 .7z ultra: 1,816,507 bytes, or 51.975%
Place no. 47

==Graphics==
=Compression of .bmp file=
Original size 4,149,414
Keka 0.1.4.3 .7z ultra: 976,233 bytes, or 76.473%
Place no. 124

=Compression of .jpg file=
Original size 842,468 bytes
Keka 0.1.4.3 .bzip2 ultra: 835,653 bytes, or .8089%
Place no. 77

==Other data==
=Compression of .hlp file=
Original size 4,121,418 bytes
Keka 0.1.4.3 .7z ultra: 613,260, or 85.1202%
Place no. 38

=Compression of .doc file=
Original size 4,168,192 bytes
Keka 0.1.4.3 .7z ultra: 790,346 bytes, or 81.0386%
Place no. 39

=Compression of .pdf file=
Original size 4,526,946 bytes
Keka 0.1.4.3 .7z ultra: 3,706,680 bytes, or 18.1196%
Place no. 34

==Summary==
Total size of the 10 tests after compression: 12,409,472 bytes
Place in Best Overall Compression Program: no. 68 out of 216

Change History (5)

comment:1 Changed 7 years ago by aONe

Cool! This benchmark is in fact for p7zip 9.13 beta, as is the binary used to compress in 7z format. Let's see the new version with p7zip 9.20!

comment:2 Changed 7 years ago by UpdateNut

It's p7zip 9.13 beta? The changelog didn't say that. Anyway, I saw that preview photo you posted on Twitter, and I look forward to Keka 0.1.5 and seeing what it can do. 8-)

comment:3 Changed 7 years ago by aONe

I forgot to write it in the changelog. Lucky not in the credits.

Actually I'm versioning it as 1.0, since the App Store is not compatible with my current 0.1.X.X, it just let X.X.X. And the code is almost all new, so fresh start. Some people will be mad about that versioning thing... Sunday can be a good day :)

comment:4 Changed 7 years ago by aONe

I must create a forum, this is turning into that!

comment:5 Changed 7 years ago by aONe

Keywords: benchmark added
Priority: minortrivial
Resolution: worksforme
Status: newclosed
Type: enhancementtask
Version: 1.0

Further benchmarking on the Forum: http://www.kekaosx.com/forum/viewtopic.php?f=6&t=7

Note: See TracTickets for help on using tickets.