the Mac OS X file archiver
Download Changelog Forum Help Trac Project

Opened 8 years ago

Closed 8 years ago

#15 closed defect (fixed)

Operation failed with error 10 compressing large directory.

Reported by: mpeterson Owned by:
Priority: blocker Milestone: Keka 1.0
Component: Version: 0.1.5b1
Keywords: Cc:


I'm compressing a directory 10GB in size with almost 27,000 files in it. The compression process fails at about the same point in progress each time. I used different methods and the file written is around 270MB in size each time (but slightly different size depending on method).
Format: ZIP
No split
No password
No exclude resource forks
No delete after compression

Version 0.1.5b1 (131)

Change History (9)

comment:1 Changed 8 years ago by mpeterson

Does NOT occur using released version of Keka (87)

comment:2 Changed 8 years ago by aONe

Sadly, I can't found any information about error code 10 for p7zip-7zip.

I'm testing it compressing the Developer folder (10+GB and 100.000+ files). 15 minutes left, will tell you then.

It's strange that with it works, as booth versions use the same p7zip 9.13, but beta1 is patched for progress control...

I assume that you used same output target with beta and stable versions.

comment:3 Changed 8 years ago by mpeterson

Yes, the same output target type and destination (ZIP, same folder).

comment:4 Changed 8 years ago by aONe

I've tried with the Developer folder and It worked fine. Can you test it again with the same folder or a similar one? Maybe there's some file that broke the process...

comment:5 Changed 8 years ago by mpeterson

I will try again.
When I originally found the problem, I tried several different directories with similar contents (they are daily builds directories). It does seem like a certain file may be to blame since the various strengths of compression I tried all seemed to fail in roughly the same place, but with slightly different end sizes, while using the same compression strength several times over resulted in exactly the same end file size. Can I turn on logging to see which file it is working on when it fails?

comment:6 Changed 8 years ago by aONe

Really there's no easy way to log right now. I've lost beta 1 source code in the transition to XCode 4, as soon as beta 2 is more or less stable (now it's very buggy) I will turn some kind of log. Hopefully next week.

comment:7 Changed 8 years ago by aONe

Right, I've made it. I recommend do not use it this version so your system log will be printed without a good reason. To see the output just open the, and search for Keka if needed.

Here's the link: Keka 0.1.5b2 R141

Last edited 8 years ago by aONe (previous) (diff)

comment:8 Changed 8 years ago by mpeterson

0.1.5b2 worked without error! I tried the same directory on 0.1.5b1 and it failed with the same error as reported above.

comment:9 Changed 8 years ago by aONe

Resolution: fixed
Status: newclosed

I mark this error as fixed then :)

Note: See TracTickets for help on using tickets.